דף הבית >> מאמרים על מסחר במט"ח >> מסחר אוטומטי >> מה צופה העתיד של מטה טרידר? ועידכון גירסה 600
מה צופה העתיד של מטה טרידר? ועידכון גירסה 600

נושא בוער בשבועות האחרונים מדבר על עידכון לגירסה 600 שחברת
META TRADER  עושה בימים אלו.MQL4 מטה טרידר
המון בעיות נוצרו מהשינוי ומשפיעות על עולם המסחר האוטומטי במט"ח.

אלפי הודעות בפורום על תקלות, איטיות, תקיעת מערכת המסחר.

אקספרטים שהיו בנויות מפסיקים לעבוד.

אינדיקטורים משתבשים.

למה זה קורה?
מה ההיגיון למהלך הזה ?
מה עושים על מנת לפתור זאת?



נתחיל עם ה"למה" ?
חברת METAQOUTES  שמפעילה את מערכת המסחר META TRADER  ,
עושה מאמצים אדירים לנהל מאבק באלפי האתרים שבנה עסקים שלמים על התשתית התוכנה שלהם.
אתרים כמו MYFXBOOK, Mt4I, אתרי EA  למינהם, אתרים שמפסקים שירותי קופיירים (COPYER- העתקת עסקאות),
אתרים שמספקים שירותי תכנות לבניית אקספרטים ועוד.

ההיגיון מאוד פשוט, להחזיר את עשרות מיליוני הדולרים חזרה לחברה.

מה עשו בשינוי?
החברה עשה שינוי בשפת התכנות מmql4 – לשפה שדומה לMql5.
עשו שינוי בDLL.
עשו שינוי בסדר התיקיות.
הורידו פקודות, הוסיפו פקודות קוד אחרות.

איך זה השפיע בפועל על הסוחר הפרטי?
אם היה לך אקספרט (EA) שהוא קוד סגור,
בגירסה החדשה הוא לא יעבוד או יעבוד אבל יכול לקרות שיבושים.
אם יש לך קוד פתוח תוכל לעשות COMPLE  (הסבר טכני בסוף).

מה הלאה?
אם אתה סוחר עם אקספרטים שבנו לך כמו שאנו בונים ללקוחותינו בהזמנה אישית,
זה הזמן לפנות למתכנת שלך , לעשות לבצע שידרוג והתאמה של הרובוט.
כרגע אפשר לעבוד עדיין עם הגרסאות הישנות, אבל לא לאורך זמן זה יתאפשר.
בנתיים אפשר לא לעשות את עידכון הגרסה שקופץ.

להלן המפרט הטכני לשינוי:
תחילה, יש לבדוק את גירסת הפלטפורמה בה אתה משתמש:  About > Help  
במידה והגרסה בה אתה משתמש בפלטפורמה היא מעל 509 (Build 509), אנא בצע את הפעולות הבאות:

שלב 1:
אם אתה משתמש באקספרטים או/ו באינדיקטורים בטרמינל MT4– יהיה עליך לשמור אותם תחת התיקיות הבאות:
אקספרטים   : MT4 > MQL4 > Experts 
אינדיקטורים: MT4 > MQL4 > Indicators

שלב 2:
אם אתה משתמש באקספרטים או/ו אינדיקטורים מצד שלישי (Third Party EA), יהיה עליך לפנות ישירות אליהם לבקשת קוד מעודכן.  
או
אם אתה משתמש באקספרטים  או/ו אינדיקטורים מותאמים אישית, יהיה עליך לעדכן אותם בתוך פלטפורמת  MT4  על פי ההוראות הבאות:
1.      פתח במערכת המסחר את ה- MetaEditor. ניתן למצוא אותו בסרגל הכלים העליון
2.      פתח את חלון  ה- Navigator  ולחץ לחיצה כפולה על האקספרט שברצונך לעדכן.
3.       לחץ על compile בסרגל הכלים העליון בחלון הראשי
4.      במידה והאקספרט עודכן בהצלחה, תוכל לראות בתיבת הדו שיח, בחלק התחתון של המסך, את ההערה ‘0 Errors’. במידה ובתיבת הדו שיח מופיעות הערות אחרות, עליך לבצע שינויים על מנת להתאים את האקספרט לגירסה המשודרגת של MT4.
5.      עם סיום התהליך יש להפעיל מחדש את מערכת ה- MT4 על מנת להשתמש באקספרט שעדכנת.
לקבלת מידע נוסף בנושא גירסת build 600 החדשה היכנס ל- MQL4 forum: 
http://forum.mql4.com/60555

 
 
לפרטים בנושא תכנות למטה טרידר- השאר את פריטיך כאן בטופס שמתחת:


 
 
                     

Go Back  Print  Send Page
             Share
רובוט נשר מסחר במט"ח

חזור למעלה            |            הוספה למועדפים            |           מפת האתר           |         יצירת קשר
 

           
תנאי שימוש
   © כל הזכויות שמורות לקבוצת יוזמה.